<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#" amp="">
<head>
<meta charset="utf-8">
<meta http-equiv="x-ua-compatible" content="ie=edge">
<meta name="viewport" content="width=device-width,initial-scale=1,minimum-scale=1,maximum-scale=1,user-scalable=no">
<title>Watch LIVE! - Foton vs. Sta. Lucia | PSL All Filipino</title>
<!-- This site is optimized with the Yoast SEO plugin v8.1.2 - https://yoast.com/wordpress/plugins/seo/ --><meta name="description" content="Will the Foton Tornadoes score its third win in as many starts? Or will Sta. Lucia get its first victory. Watch the game here live!">
<link rel="canonical" href="https://volleyverse.com/phi/psl-all-filipino-w/foton-vs-sta-lucia-livestream/">
<meta property="og:locale" content="en_US">
<meta property="og:type" content="article">
<meta property="og:title" content="Watch LIVE! - Foton vs. Sta. Lucia | PSL All Filipino">
<meta property="og:description" content="Will the Foton Tornadoes score its third win in as many starts? Or will Sta. Lucia get its first victory. Watch the game here live!">
<meta property="og:url" content="https://volleyverse.com/phi/psl-all-filipino-w/foton-vs-sta-lucia-livestream/">
<meta property="og:site_name" content="Volleyverse">
<meta property="article:publisher" content="https://www.facebook.com/volleyverse">
<meta property="article:author" content="http://www.facebook.com/lancefernandez">
<meta property="article:section" content="PSL All Filipino">
<meta property="article:published_time" content="2018-11-08T00:33:21+00:00">
<meta property="og:image" content="https://cdn.volleyverse.com/wp-content/uploads/2018/11/06020947/Foton-Tornadoes-Blue-Energy.jpg">
<meta property="og:image:secure_url" content="https://cdn.volleyverse.com/wp-content/uploads/2018/11/06020947/Foton-Tornadoes-Blue-Energy.jpg">
<meta property="og:image:width" content="1500">
<meta property="og:image:height" content="844">
<meta property="og:image:alt" content="Carmina Aganon, Jennilyn Reyes, Gyzelle Sy, Ma. Shaya Adorador, Maika Ortiz, and Ivy Perez of the Foton Tornadoes Blue Energy celebrate after getting a point against the Generika Ayala Lifesavers in their PSL All Filipino Conference 2018 match.">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:description" content="Will the Foton Tornadoes score its third win in as many starts? Or will Sta. Lucia get its first victory. Watch the game here live!">
<meta name="twitter:title" content="Watch LIVE! - Foton vs. Sta. Lucia | PSL All Filipino">
<meta name="twitter:site" content="@volleyverse">
<meta name="twitter:image" content="https://cdn.volleyverse.com/wp-content/uploads/2018/11/06020947/Foton-Tornadoes-Blue-Energy.jpg">
<meta name="twitter:creator" content="@lancefernandez">
<script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"NewsArticle","url":"https:\/\/volleyverse.com\/phi\/psl-all-filipino-w\/foton-vs-sta-lucia-livestream\/","@id":"https:\/\/volleyverse.com\/#organization","name":"Volleyverse","headline":"Watch LIVE! - Foton vs. Sta. Lucia","author":"Lawrence Fernandez","datePublished":"2018-11-08 00:33:21","dateModified":"2018-11-08T00:33:21+00:00","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/volleyverse.com\/phi\/psl-all-filipino-w\/foton-vs-sta-lucia-livestream\/"},"publisher":{"@type":"Organization","name":"Volleyverse","logo":{"@type":"ImageObject","url":"https:\/\/volleyverse.com\/wp-content\/uploads\/2015\/07\/volleyverse_logo_retina_480x127.png"}},"image":{"@type":"ImageObject","contentUrl":"https:\/\/cdn.volleyverse.com\/wp-content\/uploads\/2018\/11\/06020947\/Foton-Tornadoes-Blue-Energy.jpg","width":"1500px","height":"844px","url":"https:\/\/cdn.volleyverse.com\/wp-content\/uploads\/2018\/11\/06020947\/Foton-Tornadoes-Blue-Energy.jpg"}}</script><script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/volleyverse.com\/phi\/","name":"Philippines"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/volleyverse.com\/phi\/psl-all-filipino-w\/","name":"PSL All Filipino"}},{"@type":"ListItem","position":3,"item":{"@id":"https:\/\/volleyverse.com\/phi\/psl-all-filipino-w\/foton-vs-sta-lucia-livestream\/","name":"Watch LIVE! &#8211; Foton vs. Sta. Lucia"}}]}</script><!-- / Yoast SEO plugin. --><link rel="dns-prefetch" href="//cdn.ampproject.org">
<link rel="dns-prefetch" href="//s.w.org">
<link rel="alternate" type="application/rss+xml" title="Volleyverse » Watch LIVE! – Foton vs. Sta. Lucia Comments Feed" href="https://volleyverse.com/phi/psl-all-filipino-w/foton-vs-sta-lucia-livestream/feed/">
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.2.3 - Using Analytics tracking - https://www.monsterinsights.com/ --><!-- / Google Analytics by MonsterInsights --><style amp-boilerplate>body{-webkit-animation:-amp-start 8s steps(1,end) 0s 1 normal both;-moz-animation:-amp-start 8s steps(1,end) 0s 1 normal both;-ms-animation:-amp-start 8s steps(1,end) 0s 1 normal both;animation:-amp-start 8s steps(1,end) 0s 1 normal both}@-webkit-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@-moz-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@-ms-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@-o-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}</style>
<noscript><style amp-boilerplate>body{-webkit-animation:none;-moz-animation:none;-ms-animation:none;animation:none}</style></noscript>
<style amp-custom>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</style>
<script type="text/javascript" src="https://cdn.ampproject.org/v0.js" async></script><link rel="https://api.w.org/" href="https://volleyverse.com/wp-json/">
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://volleyverse.com/xmlrpc.php?rsd">
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://volleyverse.com/wp-includes/wlwmanifest.xml">
<meta name="generator" content="WordPress 4.9.8">
<link rel="shortlink" href="https://volleyverse.com/?p=17524">
<link rel="alternate" type="application/json+oembed" href="https://volleyverse.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvolleyverse.com%2Fphi%2Fpsl-all-filipino-w%2Ffoton-vs-sta-lucia-livestream%2F">
<link rel="alternate" type="text/xml+oembed" href="https://volleyverse.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvolleyverse.com%2Fphi%2Fpsl-all-filipino-w%2Ffoton-vs-sta-lucia-livestream%2F&amp;format=xml">
<meta name="generator" content="AMP Plugin v0.7.2">
<link rel="icon" href="https://cdn.volleyverse.com/wp-content/uploads/2016/03/08160348/cropped-volleyverse_site_identity_logo-1-50x50.png" sizes="32x32">
<link rel="icon" href="https://cdn.volleyverse.com/wp-content/uploads/2016/03/08160348/cropped-volleyverse_site_identity_logo-1-200x200.png" sizes="192x192">
<link rel="apple-touch-icon-precomposed" href="https://cdn.volleyverse.com/wp-content/uploads/2016/03/08160348/cropped-volleyverse_site_identity_logo-1-200x200.png">
<meta name="msapplication-TileImage" content="https://cdn.volleyverse.com/wp-content/uploads/2016/03/08160348/cropped-volleyverse_site_identity_logo-1.png">
<link rel="apple-touch-icon" sizes="180x180" href="https://volleyverse.com/apple-touch-icon.png">
<link rel="apple-touch-startup-image" href="https://volleyverse.com/apple-touch-icon.png">
<link rel="icon" type="image/png" href="https://volleyverse.com/favicon-32x32.png" sizes="32x32">
<link rel="icon" type="image/png" href="https://volleyverse.com/favicon-16x16.png" sizes="16x16">
<link rel="mask-icon" href="https://volleyverse.com/safari-pinned-tab.svg" color="#5bbad5">
<meta name="theme-color" content="#ffffff">
<meta name="apple-mobile-web-app-title" content="Volleyverse">
<meta name="apple-mobile-web-app-capable" content="yes">
<link rel="manifest" href="https://volleyverse.com/manifest.json">
<script type='text/javascript' src='https://cdn.ampproject.org/v0/amp-analytics-latest.js' async custom-element="amp-analytics"></script>
<script type='text/javascript' src='https://cdn.ampproject.org/v0/amp-social-share-latest.js' async custom-element="amp-social-share"></script>
<script type='text/javascript' src='https://cdn.ampproject.org/v0/amp-iframe-latest.js' async custom-element="amp-iframe"></script>
<script type='text/javascript' src='https://cdn.ampproject.org/v0/amp-sidebar-latest.js' async custom-element="amp-sidebar"></script>
</head>
<body class="post-template-default single single-post postid-17524 single-format-standard foton-vs-sta-lucia-livestream sidebar-primary">
    <!--[if IE]>
      <div class="alert alert-warning">
        You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> to improve your experience.      </div>
    <![endif]-->
    <amp-sidebar id="sidebar1" layout="nodisplay" side="right" class="amp-sidebar"><!--    <div class="promoter">--><!----><!--    </div>--><div class="menu-amp-sidebar-container"><ul id="menu-amp-sidebar" class="menu">
<li id="menu-item-14657" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14657"><a href="https://volleyverse.com/volleyball-news/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/volleyball-news/" data-vars-label="News">News</a></li>
<li id="menu-item-14769" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14769"><a href="https://volleyverse.com/features/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/features/" data-vars-label="Features">Features</a></li>
<li id="menu-item-14676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14676"><a href="https://volleyverse.com/volleyball-countries/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/volleyball-countries/" data-vars-label="Regions">Regions</a></li>
<li id="menu-item-14675" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14675"><a href="https://volleyverse.com/volleyball-competitions/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/volleyball-competitions/" data-vars-label="Competitions">Competitions</a></li>
<li id="menu-item-15296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15296"><a href="/teams/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="/teams/" data-vars-label="Teams">Teams</a></li>
<li id="menu-item-15295" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15295"><a href="/players/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="/players/" data-vars-label="Players">Players</a></li>
<li id="menu-item-15299" class="small-link first-small-link menu-item menu-item-type-post_type menu-item-object-page menu-item-15299"><a href="https://volleyverse.com/about-us/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/about-us/" data-vars-label="About Us">About Us</a></li>
<li id="menu-item-16257" class="small-link menu-item menu-item-type-post_type menu-item-object-page menu-item-16257"><a href="https://volleyverse.com/volleymojis-volleyball-stickers-emojis/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/volleymojis-volleyball-stickers-emojis/" data-vars-label="Volleyball Stickers">Volleyball Stickers</a></li>
<li id="menu-item-15300" class="small-link menu-item menu-item-type-post_type menu-item-object-page menu-item-15300"><a href="https://volleyverse.com/partnerships/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/partnerships/" data-vars-label="Partnerships">Partnerships</a></li>
<li id="menu-item-15301" class="small-link menu-item menu-item-type-post_type menu-item-object-page menu-item-15301"><a href="https://volleyverse.com/jobs/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/jobs/" data-vars-label="Jobs">Jobs</a></li>
<li id="menu-item-15297" class="small-link menu-item menu-item-type-post_type menu-item-object-page menu-item-15297"><a href="https://volleyverse.com/privacy-cookie-policy/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/privacy-cookie-policy/" data-vars-label="Privacy &amp;amp; Cookie Policy">Privacy &amp; Cookie Policy</a></li>
<li id="menu-item-15298" class="small-link menu-item menu-item-type-post_type menu-item-object-page menu-item-15298"><a href="https://volleyverse.com/terms-of-use/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/terms-of-use/" data-vars-label="Terms Of Use">Terms Of Use</a></li>
</ul></div>    <!--    <div class="app-assets">-->
    <!--        <a href="#"  class="app stickers"> <amp-img class="nav-sticker" width="30" height="30" layout="fixed" src="-->
	<!--/dist/images/sticker-icon.svg"></amp-img> Stickers</a>-->
    <!---->
    <!--        <a href="#"  class="app app-android"></a>-->
    <!--        <a href="#"  class="app app-apple"></a>-->
    
</amp-sidebar><nav class="navigation"><a href="https://volleyverse.com" class="brand monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com" data-vars-label=""></a>

	<div class="menu-amp-header-container"><ul id="menu-amp-header" class="nav">
<li id="menu-item-14706" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14706"><a href="https://volleyverse.com/volleyball-news/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/volleyball-news/" data-vars-label="News">News</a></li>
<li id="menu-item-14770" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14770"><a href="https://volleyverse.com/features/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/features/" data-vars-label="Features">Features</a></li>
<li id="menu-item-14652" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14652"><a href="https://volleyverse.com/volleyball-countries/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/volleyball-countries/" data-vars-label="Regions">Regions</a></li>
<li id="menu-item-14655" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14655"><a href="https://volleyverse.com/volleyball-competitions/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/volleyball-competitions/" data-vars-label="Competitions">Competitions</a></li>
<li id="menu-item-14617" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14617"><a href="https://volleyverse.com/teams/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/teams/" data-vars-label="Teams">Teams</a></li>
<li id="menu-item-14616" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14616"><a href="https://volleyverse.com/players/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/players/" data-vars-label="Players">Players</a></li>
</ul></div>
    <a href="#" class="sticker-cta monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="#" data-vars-label="
        

        Volleyverse Stickers
    ">
        <amp-img class="nav-sticker" width="30" height="30" layout="fixed" src="https://volleyverse.com/wp-content/themes/volleyverse-amp-2018/dist/images/sticker-icon.svg"></amp-img>

        Volleyverse Stickers
    </a>

    <div class="aux-links">
        <a href="https://line.me/S/sticker/4877038" class="app app-sticker-temp monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://line.me/S/sticker/4877038" data-vars-label=""></a>
        <a href="#" class="app app-sticker monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="#" data-vars-label=""></a>
        <a href="#" class="app app-android monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="#" data-vars-label=""></a>
        <a href="#" class="app app-apple monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="#" data-vars-label=""></a>


        <button class="hamburger" on="tap:sidebar1.toggle"></button>
    </div>
	        <div class="second-nav">
            <div class="container">
                <div class="cont-75">
					
<p id="breadcrumbs"><span><span><a href="https://volleyverse.com/phi/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/" data-vars-label="Philippines">Philippines</a> &gt; <span><a href="https://volleyverse.com/phi/psl-all-filipino-w/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/" data-vars-label="PSL All Filipino">PSL All Filipino</a></span> &gt;</span></span></p>


											
                        <div class="sub-nav">
                            <ul>
<li>
                                    <a href="https://volleyverse.com/phi/psl-all-filipino-w" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w" data-vars-label="News">News</a>
                                </li>

								
                                    <!--                    <li>-->
                                    <!--                        <a href="#">Table</a>-->
                                    <!--                    </li>-->

								
								

								


                                <li>

                                    <a href="https://volleyverse.com/phi/psl-all-filipino-w/teams/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/teams/" data-vars-label="Teams">Teams</a>
                                </li>

                                
								                            </ul>
</div>

					                </div>
            </div>
        </div>
		</nav><div class="wrap container" role="document">
      <div class="content row">
          <div class="intial-assets-space"><a href="https://line.me/S/sticker/4877038" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://line.me/S/sticker/4877038" data-vars-label="

                  ">

                  <amp-img alt="Volleyverse Stickers" src="https://volleyverse.com/wp-content/themes/volleyverse-amp-2018/dist/images/sticker-promo-2.jpg" width="290" height="290" layout="responsive"></amp-img></a></div>
        <main class="main"><div class="container">
                <div class="row">
          

        <div class="single-page-post">
            <div class="row">



            </div>


            <h1>Watch LIVE! – Foton vs. Sta. Lucia</h1>
            <div class="meta">

				Thursday, 08 Nov 2018
				                <br><!-- Author Start --><!-- Author Start --><!-- Author Start --><!-- Author Start --><!-- Author Start --><!-- Author Start -->Lawrence Fernandez<!-- Author End --><!-- Author End --><!-- Author End --><!-- Author End --><!-- Author End --><!-- Author End -->   - Editor  - <a href="https://twitter.com/lancefernandez" target="_blank" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://twitter.com/lancefernandez" data-vars-label="@lancefernandez">@lancefernandez</a>

            </div>
			    <div class="hero-image">
        <a href="https://volleyverse.com/phi/psl-all-filipino-w/foton-vs-sta-lucia-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/foton-vs-sta-lucia-livestream/" data-vars-label="
            ">
            <amp-img width="750" height="419" src="https://cdn.volleyverse.com/wp-content/uploads/2018/11/06020947/Foton-Tornadoes-Blue-Energy-750x419.jpg" class="attachment-large-letterbox-new size-large-letterbox-new wp-post-image amp-wp-enforced-sizes" alt="Carmina Aganon, Jennilyn Reyes, Gyzelle Sy, Ma. Shaya Adorador, Maika Ortiz, and Ivy Perez of the Foton Tornadoes Blue Energy celebrate after getting a point against the Generika Ayala Lifesavers in their PSL All Filipino Conference 2018 match." layout="intrinsic"></amp-img></a>
    </div>

							<div class="row amp-share ">

    <amp-social-share type="facebook" data-param-app_id="289467951404533" class="col" height="26"></amp-social-share><amp-social-share type="twitter" class="col" height="26"></amp-social-share><amp-social-share type="whatsapp" class="col" height="26"></amp-social-share><amp-social-share type="messenger" data-share-endpoint="fb-messenger://share" data-param-link="CANONICAL_URL" class="col amp-social-share-messenger" height="26"></amp-social-share><amp-social-share type="viber" data-share-endpoint="viber://forward" data-param-link="CANONICAL_URL" class="col amp-social-share-viber" height="26"></amp-social-share><amp-social-share type="line" class="col" height="26"></amp-social-share>
</div>            <div class="single-content">

				<p><!-- Article Start -->The <a href="https://volleyverse.com/teams/2828/foton-tornadoes/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/teams/2828/foton-tornadoes/" data-vars-label="Foton Tornadoes">Foton Tornadoes</a> Blue Energy has won its first two games with big contributions from <a href="https://volleyverse.com/players/4581/carmina-aganon/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/players/4581/carmina-aganon/" data-vars-label="Carmina Aganon">Carmina Aganon</a>, <a href="https://volleyverse.com/players/4423/maika-ortiz/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/players/4423/maika-ortiz/" data-vars-label="Maika Ortiz">Maika Ortiz</a> and Ma. <a href="https://volleyverse.com/players/17111/shaya-adorador/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/players/17111/shaya-adorador/" data-vars-label="Shaya Adorador">Shaya Adorador</a>. They will be facing the <a href="https://volleyverse.com/teams/5805/sta-lucia-realtors/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/teams/5805/sta-lucia-realtors/" data-vars-label="Sta. Lucia Realtors">Sta. Lucia Realtors</a> who are still seeking for their first victory while <a href="https://volleyverse.com/players/17042/toni-rose-basas/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/players/17042/toni-rose-basas/" data-vars-label="Toni Rose Basas">Toni Rose Basas</a> and <a href="https://volleyverse.com/players/17050/mj-phillips/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/players/17050/mj-phillips/" data-vars-label="MJ Phillips">MJ Phillips</a> are still questionable. However, <a href="https://volleyverse.com/players/17036/rebecca-rivera/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/players/17036/rebecca-rivera/" data-vars-label="Rebecca Rivera">Rebecca Rivera</a>, Pam Lastimosa, and <a href="https://volleyverse.com/players/10952/jhoana-maraguinot/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/players/10952/jhoana-maraguinot/" data-vars-label="Jhoana Maraguinot">Jhoana Maraguinot</a> have played good in those two games. Will Foton speed up to win number three? Or will Sta. Lucia claim its first win? Watch this <a href="https://volleyverse.com/phi/psl-all-filipino-w/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/" data-vars-label="PSL All Filipino">PSL All Filipino</a> Conference 2018 match via livestream here.</p>
<p></p>
<center><amp-iframe src="https://www.youtube.com/embed/SNF39G1c0sM" width="560" height="315" frameborder="0" allowfullscreen="" sandbox="allow-scripts allow-same-origin" layout="intrinsic" class="amp-wp-enforced-sizes"><div placeholder="" class="amp-wp-iframe-placeholder"></div></amp-iframe></center> <!-- Article End -->

                
            </div>
			<div class="row amp-share ">

    <amp-social-share type="facebook" data-param-app_id="289467951404533" class="col" height="26"></amp-social-share><amp-social-share type="twitter" class="col" height="26"></amp-social-share><amp-social-share type="whatsapp" class="col" height="26"></amp-social-share><amp-social-share type="messenger" data-share-endpoint="fb-messenger://share" data-param-link="CANONICAL_URL" class="col amp-social-share-messenger" height="26"></amp-social-share><amp-social-share type="viber" data-share-endpoint="viber://forward" data-param-link="CANONICAL_URL" class="col amp-social-share-viber" height="26"></amp-social-share><amp-social-share type="line" class="col" height="26"></amp-social-share>
</div>        </div>
        <div class="separators">
                        <div class="separator-block related">
                <h3>Related</h3>
                <div class="single-post row latest-post">


						                            <div class="col-sm-4">
                                <div class="row">
                                    <div class="col-12 single-post-thumb single-post-thumb-sm">
                                        <a href="https://volleyverse.com/phi/psl-all-filipino-w/petron-blaze-spikers-vs-smart-giga-hitters-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/petron-blaze-spikers-vs-smart-giga-hitters-livestream/" data-vars-label=""><amp-img src="https://cdn.volleyverse.com/wp-content/uploads/2018/11/08004852/Mika-Reyes-230x130.jpg" width="230" height="130" class="amp-wp-enforced-sizes" layout="intrinsic"></amp-img></a>
                                    </div>
                                    <div class="col-100 single-post-thumb single-post-thumb-lg">
                                        <a href="https://volleyverse.com/phi/psl-all-filipino-w/petron-blaze-spikers-vs-smart-giga-hitters-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/petron-blaze-spikers-vs-smart-giga-hitters-livestream/" data-vars-label=""><amp-img src="https://cdn.volleyverse.com/wp-content/uploads/2018/11/08004852/Mika-Reyes-100x100.jpg" width="100" height="100" class="amp-wp-enforced-sizes" layout="intrinsic"></amp-img></a>
                                    </div>

                                    <div class="col single-post-info">
										                                        <a class="filter-link monsterinsights-outbound-link" href="https://volleyverse.com/phi/psl-all-filipino-w/" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/" data-vars-label="PSL All Filipino">PSL All Filipino</a>
                                        <a href="https://volleyverse.com/phi/psl-all-filipino-w/petron-blaze-spikers-vs-smart-giga-hitters-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/petron-blaze-spikers-vs-smart-giga-hitters-livestream/" data-vars-label="
                                            Watch LIVE! – Petron vs. Smart
                                        ">
                                            <h3 class="smaller-h3">Watch LIVE! – Petron vs. Smart</h3>
                                        </a>
                                    </div>
                                </div>
                            </div>
						                            <div class="col-sm-4">
                                <div class="row">
                                    <div class="col-12 single-post-thumb single-post-thumb-sm">
                                        <a href="https://volleyverse.com/phi/psl-all-filipino-w/f2-logistics-vs-cocolife-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/f2-logistics-vs-cocolife-livestream/" data-vars-label=""><amp-img src="https://cdn.volleyverse.com/wp-content/uploads/2016/11/08154031/aby-marano-f2-logistics-foton-tornadoes-230x130.jpg" width="230" height="130" class="amp-wp-enforced-sizes" layout="intrinsic"></amp-img></a>
                                    </div>
                                    <div class="col-100 single-post-thumb single-post-thumb-lg">
                                        <a href="https://volleyverse.com/phi/psl-all-filipino-w/f2-logistics-vs-cocolife-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/f2-logistics-vs-cocolife-livestream/" data-vars-label=""><amp-img src="https://cdn.volleyverse.com/wp-content/uploads/2016/11/08154031/aby-marano-f2-logistics-foton-tornadoes-100x100.jpg" width="100" height="100" class="amp-wp-enforced-sizes" layout="intrinsic"></amp-img></a>
                                    </div>

                                    <div class="col single-post-info">
										                                        <a class="filter-link monsterinsights-outbound-link" href="https://volleyverse.com/phi/psl-all-filipino-w/" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/" data-vars-label="PSL All Filipino">PSL All Filipino</a>
                                        <a href="https://volleyverse.com/phi/psl-all-filipino-w/f2-logistics-vs-cocolife-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/f2-logistics-vs-cocolife-livestream/" data-vars-label="
                                            Watch LIVE! – F2 Logistics vs. Cocolife
                                        ">
                                            <h3 class="smaller-h3">Watch LIVE! – F2 Logistics vs. Cocolife</h3>
                                        </a>
                                    </div>
                                </div>
                            </div>
						                            <div class="col-sm-4">
                                <div class="row">
                                    <div class="col-12 single-post-thumb single-post-thumb-sm">
                                        <a href="https://volleyverse.com/phi/psl-all-filipino-w/petron-blaze-spikers-vs-generika-ayala-lifesavers-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/petron-blaze-spikers-vs-generika-ayala-lifesavers-livestream/" data-vars-label=""><amp-img src="https://cdn.volleyverse.com/wp-content/uploads/2018/11/01093146/Petron-vs-Cocolife-230x130.jpg" width="230" height="130" class="amp-wp-enforced-sizes" layout="intrinsic"></amp-img></a>
                                    </div>
                                    <div class="col-100 single-post-thumb single-post-thumb-lg">
                                        <a href="https://volleyverse.com/phi/psl-all-filipino-w/petron-blaze-spikers-vs-generika-ayala-lifesavers-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/petron-blaze-spikers-vs-generika-ayala-lifesavers-livestream/" data-vars-label=""><amp-img src="https://cdn.volleyverse.com/wp-content/uploads/2018/11/01093146/Petron-vs-Cocolife-100x100.jpg" width="100" height="100" class="amp-wp-enforced-sizes" layout="intrinsic"></amp-img></a>
                                    </div>

                                    <div class="col single-post-info">
										                                        <a class="filter-link monsterinsights-outbound-link" href="https://volleyverse.com/phi/psl-all-filipino-w/" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/" data-vars-label="PSL All Filipino">PSL All Filipino</a>
                                        <a href="https://volleyverse.com/phi/psl-all-filipino-w/petron-blaze-spikers-vs-generika-ayala-lifesavers-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/petron-blaze-spikers-vs-generika-ayala-lifesavers-livestream/" data-vars-label="
                                            Watch LIVE! Petron vs. Generika
                                        ">
                                            <h3 class="smaller-h3">Watch LIVE! Petron vs. Generika</h3>
                                        </a>
                                    </div>
                                </div>
                            </div>
						
                </div>

            </div>
                                    <div class="separator-block popular">
                <h3>Popular</h3>
                <div class="single-post row latest-post">


					
                        <div class="col-sm-4">
                            <div class="row">

                                <div class="col-12 single-post-thumb single-post-thumb-sm">
                                    <a href="https://volleyverse.com/phi/rumor-is-myla-pablo-headed-to-the-psl/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/rumor-is-myla-pablo-headed-to-the-psl/" data-vars-label="
                                        ">
                                        <amp-img src="https://cdn.volleyverse.com/wp-content/uploads/2018/10/19191303/Pocari-Sweat-Lady-Warriors-230x130.jpg" width="230" height="130" class="amp-wp-enforced-sizes" layout="intrinsic"></amp-img></a>
                                </div>
                                <div class="col-100 single-post-thumb single-post-thumb-lg">
                                    <a href="https://volleyverse.com/phi/rumor-is-myla-pablo-headed-to-the-psl/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/rumor-is-myla-pablo-headed-to-the-psl/" data-vars-label="
                                        ">
                                        <amp-img src="https://cdn.volleyverse.com/wp-content/uploads/2018/10/19191303/Pocari-Sweat-Lady-Warriors-100x100.jpg" width="100" height="100" class="amp-wp-enforced-sizes" layout="intrinsic"></amp-img></a>
                                </div>

                                <div class="col single-post-info">
									                                    <a class="filter-link monsterinsights-outbound-link" href="https://volleyverse.com/phi/" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/" data-vars-label="Philippines">Philippines</a>
                                    <a href="https://volleyverse.com/phi/rumor-is-myla-pablo-headed-to-the-psl/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/rumor-is-myla-pablo-headed-to-the-psl/" data-vars-label="
                                        Rumor: Is Myla Pablo headed to the PSL?
                                    ">
                                        <h3 class="smaller-h3">Rumor: Is Myla Pablo headed to the PSL?</h3>
                                    </a>
                                </div>
                            </div>
                        </div>

					
                        <div class="col-sm-4">
                            <div class="row">

                                <div class="col-12 single-post-thumb single-post-thumb-sm">
                                    <a href="https://volleyverse.com/phi/pvl-open-w/alyssa-valdez-injury-vs-tacloban-fighting-warays/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/pvl-open-w/alyssa-valdez-injury-vs-tacloban-fighting-warays/" data-vars-label="
                                        ">
                                        <amp-img src="https://cdn.volleyverse.com/wp-content/uploads/2017/06/08152751/alyssa-valdez-cavs-fan-1-230x130.jpg" width="230" height="130" class="amp-wp-enforced-sizes" layout="intrinsic"></amp-img></a>
                                </div>
                                <div class="col-100 single-post-thumb single-post-thumb-lg">
                                    <a href="https://volleyverse.com/phi/pvl-open-w/alyssa-valdez-injury-vs-tacloban-fighting-warays/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/pvl-open-w/alyssa-valdez-injury-vs-tacloban-fighting-warays/" data-vars-label="
                                        ">
                                        <amp-img src="https://cdn.volleyverse.com/wp-content/uploads/2017/06/08152751/alyssa-valdez-cavs-fan-1-100x100.jpg" width="100" height="100" class="amp-wp-enforced-sizes" layout="intrinsic"></amp-img></a>
                                </div>

                                <div class="col single-post-info">
									                                    <a class="filter-link monsterinsights-outbound-link" href="https://volleyverse.com/phi/pvl-open-w/" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/pvl-open-w/" data-vars-label="PVL Women&amp;#039;s Open Conference">PVL Women's Open Conference</a>
                                    <a href="https://volleyverse.com/phi/pvl-open-w/alyssa-valdez-injury-vs-tacloban-fighting-warays/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/pvl-open-w/alyssa-valdez-injury-vs-tacloban-fighting-warays/" data-vars-label="
                                        Injured Valdez leads Creamline to victory over Tacloban
                                    ">
                                        <h3 class="smaller-h3">Injured Valdez leads Creamline to victory over Tacloban</h3>
                                    </a>
                                </div>
                            </div>
                        </div>

					
                        <div class="col-sm-4">
                            <div class="row">

                                <div class="col-12 single-post-thumb single-post-thumb-sm">
                                    <a href="https://volleyverse.com/phi/pvl-open-w/watch-creamline-cool-smashers-vs-tacloban-fighting-warays-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/pvl-open-w/watch-creamline-cool-smashers-vs-tacloban-fighting-warays-livestream/" data-vars-label="
                                        ">
                                        <amp-img src="https://cdn.volleyverse.com/wp-content/uploads/2017/08/08152257/alyssa-valdez-allowed-play-creamline-230x130.jpg" width="230" height="130" class="amp-wp-enforced-sizes" layout="intrinsic"></amp-img></a>
                                </div>
                                <div class="col-100 single-post-thumb single-post-thumb-lg">
                                    <a href="https://volleyverse.com/phi/pvl-open-w/watch-creamline-cool-smashers-vs-tacloban-fighting-warays-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/pvl-open-w/watch-creamline-cool-smashers-vs-tacloban-fighting-warays-livestream/" data-vars-label="
                                        ">
                                        <amp-img src="https://cdn.volleyverse.com/wp-content/uploads/2017/08/08152257/alyssa-valdez-allowed-play-creamline-100x100.jpg" width="100" height="100" class="amp-wp-enforced-sizes" layout="intrinsic"></amp-img></a>
                                </div>

                                <div class="col single-post-info">
									                                    <a class="filter-link monsterinsights-outbound-link" href="https://volleyverse.com/phi/pvl-open-w/" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/pvl-open-w/" data-vars-label="PVL Women&amp;#039;s Open Conference">PVL Women's Open Conference</a>
                                    <a href="https://volleyverse.com/phi/pvl-open-w/watch-creamline-cool-smashers-vs-tacloban-fighting-warays-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/pvl-open-w/watch-creamline-cool-smashers-vs-tacloban-fighting-warays-livestream/" data-vars-label="
                                        Watch LIVE! – Creamline vs Tacloban
                                    ">
                                        <h3 class="smaller-h3">Watch LIVE! – Creamline vs Tacloban</h3>
                                    </a>
                                </div>
                            </div>
                        </div>

					                </div>
            </div>
                                        <div class="separator-block latest">
                <h3>Latest</h3>
                <div class="single-post row latest-post">


					                            <div class="col-sm-4">
                                <div class="row">
                                    <div class="col-12 single-post-thumb single-post-thumb-sm">
                                        <a href="https://volleyverse.com/phi/pvl-open-w/petro-gazz-vs-pocari-sweat-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/pvl-open-w/petro-gazz-vs-pocari-sweat-livestream/" data-vars-label="
											">
											<amp-img width="230" height="130" src="https://cdn.volleyverse.com/wp-content/uploads/2018/11/03090620/Petro-Gazz-Angels-230x130.jpg" class="attachment-230-letterbox size-230-letterbox wp-post-image amp-wp-enforced-sizes" alt="" srcset="https://cdn.volleyverse.com/wp-content/uploads/2018/11/03090620/Petro-Gazz-Angels-230x130.jpg 230w, https://cdn.volleyverse.com/wp-content/uploads/2018/11/03090620/Petro-Gazz-Angels-720x405.jpg 720w, https://cdn.volleyverse.com/wp-content/uploads/2018/11/03090620/Petro-Gazz-Angels.jpg 1500w" layout="intrinsic"></amp-img></a>
                                    </div>
                                    <div class="col-100 single-post-thumb single-post-thumb-lg">
                                        <a href="https://volleyverse.com/phi/pvl-open-w/petro-gazz-vs-pocari-sweat-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/pvl-open-w/petro-gazz-vs-pocari-sweat-livestream/" data-vars-label="
											">
											<amp-img width="100" height="100" src="https://cdn.volleyverse.com/wp-content/uploads/2018/11/03090620/Petro-Gazz-Angels-100x100.jpg" class="attachment-thumbnail-100 size-thumbnail-100 wp-post-image amp-wp-enforced-sizes" alt="" srcset="https://cdn.volleyverse.com/wp-content/uploads/2018/11/03090620/Petro-Gazz-Angels-100x100.jpg 100w, https://cdn.volleyverse.com/wp-content/uploads/2018/11/03090620/Petro-Gazz-Angels-200x200.jpg 200w" layout="intrinsic"></amp-img></a>
                                    </div>

                                    <div class="col single-post-info">
										                                        <a class="filter-link monsterinsights-outbound-link" href="https://volleyverse.com/phi/pvl-open-w/" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/pvl-open-w/" data-vars-label="PVL Women&amp;#039;s Open Conference">PVL Women's Open Conference</a>
                                        <a href="https://volleyverse.com/phi/pvl-open-w/petro-gazz-vs-pocari-sweat-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/pvl-open-w/petro-gazz-vs-pocari-sweat-livestream/" data-vars-label="
                                            Watch LIVE! – Petro Gazz vs. Pocari Sweat
                                        ">
                                            <h3 class="smaller-h3">Watch LIVE! – Petro Gazz vs. Pocari Sweat</h3>
                                        </a>
                                    </div>
                                </div>
                            </div>
						                            <div class="col-sm-4">
                                <div class="row">
                                    <div class="col-12 single-post-thumb single-post-thumb-sm">
                                        <a href="https://volleyverse.com/phi/psl-all-filipino-w/f2-logistics-vs-sta-lucia-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/f2-logistics-vs-sta-lucia-livestream/" data-vars-label="
											">
											<amp-img width="230" height="130" src="https://cdn.volleyverse.com/wp-content/uploads/2018/11/06041439/F2-Logistics-Cargo-Movers-03-230x130.jpg" class="attachment-230-letterbox size-230-letterbox wp-post-image amp-wp-enforced-sizes" alt="Cha Cruz-Behag, Dawn Macandili, Majoy Baron, Ara Galang, and Kim Kianna Dy of the F2 Logistics Cargo Movers" srcset="https://cdn.volleyverse.com/wp-content/uploads/2018/11/06041439/F2-Logistics-Cargo-Movers-03-230x130.jpg 230w, https://cdn.volleyverse.com/wp-content/uploads/2018/11/06041439/F2-Logistics-Cargo-Movers-03-720x405.jpg 720w, https://cdn.volleyverse.com/wp-content/uploads/2018/11/06041439/F2-Logistics-Cargo-Movers-03.jpg 1500w" layout="intrinsic"></amp-img></a>
                                    </div>
                                    <div class="col-100 single-post-thumb single-post-thumb-lg">
                                        <a href="https://volleyverse.com/phi/psl-all-filipino-w/f2-logistics-vs-sta-lucia-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/f2-logistics-vs-sta-lucia-livestream/" data-vars-label="
											">
											<amp-img width="100" height="100" src="https://cdn.volleyverse.com/wp-content/uploads/2018/11/06041439/F2-Logistics-Cargo-Movers-03-100x100.jpg" class="attachment-thumbnail-100 size-thumbnail-100 wp-post-image amp-wp-enforced-sizes" alt="Cha Cruz-Behag, Dawn Macandili, Majoy Baron, Ara Galang, and Kim Kianna Dy of the F2 Logistics Cargo Movers" srcset="https://cdn.volleyverse.com/wp-content/uploads/2018/11/06041439/F2-Logistics-Cargo-Movers-03-100x100.jpg 100w, https://cdn.volleyverse.com/wp-content/uploads/2018/11/06041439/F2-Logistics-Cargo-Movers-03-200x200.jpg 200w" layout="intrinsic"></amp-img></a>
                                    </div>

                                    <div class="col single-post-info">
										                                        <a class="filter-link monsterinsights-outbound-link" href="https://volleyverse.com/phi/psl-all-filipino-w/" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/" data-vars-label="PSL All Filipino">PSL All Filipino</a>
                                        <a href="https://volleyverse.com/phi/psl-all-filipino-w/f2-logistics-vs-sta-lucia-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/f2-logistics-vs-sta-lucia-livestream/" data-vars-label="
                                            Watch LIVE! – F2 Logistics vs. Sta. Lucia
                                        ">
                                            <h3 class="smaller-h3">Watch LIVE! – F2 Logistics vs. Sta. Lucia</h3>
                                        </a>
                                    </div>
                                </div>
                            </div>
						                            <div class="col-sm-4">
                                <div class="row">
                                    <div class="col-12 single-post-thumb single-post-thumb-sm">
                                        <a href="https://volleyverse.com/phi/psl-all-filipino-w/foton-vs-cignal-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/foton-vs-cignal-livestream/" data-vars-label="
											">
											<amp-img width="230" height="130" src="https://cdn.volleyverse.com/wp-content/uploads/2018/11/06020947/Foton-Tornadoes-Blue-Energy-230x130.jpg" class="attachment-230-letterbox size-230-letterbox wp-post-image amp-wp-enforced-sizes" alt="Carmina Aganon, Jennilyn Reyes, Gyzelle Sy, Ma. Shaya Adorador, Maika Ortiz, and Ivy Perez of the Foton Tornadoes Blue Energy celebrate after getting a point against the Generika Ayala Lifesavers in their PSL All Filipino Conference 2018 match." srcset="https://cdn.volleyverse.com/wp-content/uploads/2018/11/06020947/Foton-Tornadoes-Blue-Energy-230x130.jpg 230w, https://cdn.volleyverse.com/wp-content/uploads/2018/11/06020947/Foton-Tornadoes-Blue-Energy-720x405.jpg 720w, https://cdn.volleyverse.com/wp-content/uploads/2018/11/06020947/Foton-Tornadoes-Blue-Energy.jpg 1500w" layout="intrinsic"></amp-img></a>
                                    </div>
                                    <div class="col-100 single-post-thumb single-post-thumb-lg">
                                        <a href="https://volleyverse.com/phi/psl-all-filipino-w/foton-vs-cignal-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/foton-vs-cignal-livestream/" data-vars-label="
											">
											<amp-img width="100" height="100" src="https://cdn.volleyverse.com/wp-content/uploads/2018/11/06020947/Foton-Tornadoes-Blue-Energy-100x100.jpg" class="attachment-thumbnail-100 size-thumbnail-100 wp-post-image amp-wp-enforced-sizes" alt="Carmina Aganon, Jennilyn Reyes, Gyzelle Sy, Ma. Shaya Adorador, Maika Ortiz, and Ivy Perez of the Foton Tornadoes Blue Energy celebrate after getting a point against the Generika Ayala Lifesavers in their PSL All Filipino Conference 2018 match." srcset="https://cdn.volleyverse.com/wp-content/uploads/2018/11/06020947/Foton-Tornadoes-Blue-Energy-100x100.jpg 100w, https://cdn.volleyverse.com/wp-content/uploads/2018/11/06020947/Foton-Tornadoes-Blue-Energy-200x200.jpg 200w" layout="intrinsic"></amp-img></a>
                                    </div>

                                    <div class="col single-post-info">
										                                        <a class="filter-link monsterinsights-outbound-link" href="https://volleyverse.com/phi/psl-all-filipino-w/" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/" data-vars-label="PSL All Filipino">PSL All Filipino</a>
                                        <a href="https://volleyverse.com/phi/psl-all-filipino-w/foton-vs-cignal-livestream/" class="monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/phi/psl-all-filipino-w/foton-vs-cignal-livestream/" data-vars-label="
                                            Watch LIVE! – Foton vs. Cignal HD
                                        ">
                                            <h3 class="smaller-h3">Watch LIVE! – Foton vs. Cignal HD</h3>
                                        </a>
                                    </div>
                                </div>
                            </div>
						
                </div>

            </div>
                    </div>
		
                </div>
            </div>
        </main><!-- /.main --><div class="trending-players">
    <div class="popular-players">
        
            <aside id="text-6" class="widget widget_text"><div class="textwidget">
<div class="amp-players">
    <h3>Trending Players</h3>
<div class="row">
                    <div class="popular-player-container"><a href="https://volleyverse.com/players/17120/tyler-marie-kalei-mau/" class="players-player monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/players/17120/tyler-marie-kalei-mau/" data-vars-label="Kalei Mau"><amp-img src="https://cdn.volleyverse.com/wp-content/uploads/2018/10/28020757/kalei-mau-200x200.jpg" width="200" height="200" class="amp-wp-enforced-sizes" layout="intrinsic"></amp-img><div class="player-name">Kalei Mau</div></a></div>
                                <div class="popular-player-container"><a href="https://volleyverse.com/players/3325/alyssa-valdez/" class="players-player monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/players/3325/alyssa-valdez/" data-vars-label="Alyssa Valdez"><amp-img src="https://cdn.volleyverse.com/wp-content/uploads/2016/09/08152448/alyssa-valdez-200x200.jpg" width="200" height="200" class="amp-wp-enforced-sizes" layout="intrinsic"></amp-img><div class="player-name">Alyssa Valdez</div></a></div>
                                <div class="popular-player-container"><a href="https://volleyverse.com/players/11415/myla-pablo/" class="players-player monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/players/11415/myla-pablo/" data-vars-label="Myla Pablo"><amp-img src="https://cdn.volleyverse.com/wp-content/uploads/2017/10/09183151/myla-pablo-200x200.jpg" width="200" height="200" class="amp-wp-enforced-sizes" layout="intrinsic"></amp-img><div class="player-name">Myla Pablo</div></a></div>
                                <div class="popular-player-container"><a href="https://volleyverse.com/players/3452/jheck-dionela/" class="players-player monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/players/3452/jheck-dionela/" data-vars-label="Jheck Dionela"><amp-img src="https://cdn.volleyverse.com/wp-content/uploads/2016/06/08155416/Jheck-200x200.jpg" width="200" height="200" class="amp-wp-enforced-sizes" layout="intrinsic"></amp-img><div class="player-name">Jheck Dionela</div></a></div>
                                <div class="popular-player-container"><a href="https://volleyverse.com/players/4577/christine-joy-rosario/" class="players-player monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/players/4577/christine-joy-rosario/" data-vars-label="CJ Rosario"><amp-img src="https://cdn.volleyverse.com/wp-content/uploads/2017/08/08152357/christine-joy-rosario-200x200.jpg" width="200" height="200" class="amp-wp-enforced-sizes" layout="intrinsic"></amp-img><div class="player-name">CJ Rosario</div></a></div>
                                <div class="popular-player-container"><a href="https://volleyverse.com/players/10935/katrina-tolentino/" class="players-player monsterinsights-outbound-link" data-vars-category="outbound-link" data-vars-action="https://volleyverse.com/players/10935/katrina-tolentino/" data-vars-label="Kat Tolentino"><amp-img src="https://cdn.volleyverse.com/wp-content/uploads/2017/09/28180058/kat-tolentino-200x200.jpg" width="200" height="200" class="amp-wp-enforced-sizes" layout="intrinsic"></amp-img><div class="player-name">Kat Tolentino</div></a></div>
                    </div>

</div>

</div>
		</aside>
</div>
</div>
                  <aside class="sidebar"></aside><!-- /.sidebar -->
</div>
<!-- /.content -->
    </div>
<!-- /.wrap -->
    <footer class="content-info"><div class="container">
<!--        <p>Copyright Volleyverse.com --><!-- &copy;</p> <a class="back-to-top-link" href="#main">Back to top</a>-->
    </div>
</footer><amp-pixel src="https://volleyverse.com/index.php?pixel=true&amp;id=17524&amp;bust=RANDOM" layout="nodisplay"></amp-pixel><amp-analytics id="monsterinsights-googleanalytics" type="googleanalytics" config="//volleyverse.com/wp-json/monsterinsights/amp.json" data-credentials="include"><script type="application/json">{"vars":{"account":"UA-62953521-1"},"triggers":{"trackPageview":{"on":"visible","request":"pageview"},"downloadLinks":{"on":"click","selector":"a, .monsterinsights-download","request":"event","vars":{"eventCategory":"${category}","eventAction":"${action}","eventLabel":"${label}"}},"internalAsOutboundLinks":{"on":"click","selector":"a, .monsterinsights-internal-as-outbound","request":"event","vars":{"eventCategory":"${category}","eventAction":"${action}","eventLabel":"${label}"}},"outboundLinks":{"on":"click","selector":"a, .monsterinsights-outbound-link","request":"event","vars":{"eventCategory":"${category}","eventAction":"${action}","eventLabel":"${label}"}},"telLinks":{"on":"click","selector":"a, .monsterinsights-tel","request":"event","vars":{"eventCategory":"${category}","eventAction":"${action}","eventLabel":"${label}"}},"mailtoLinks":{"on":"click","selector":"a, .monsterinsights-mailto","request":"event","vars":{"eventCategory":"${category}","eventAction":"${action}","eventLabel":"${label}"}}}}</script></amp-analytics>
</body>
</html>